Realtek HD: Ploppen am Klinkenausgang nach Inaktivität verhindern

Kommentare zu folgendem Beitrag: Realtek HD: Ploppen am Klinkenausgang nach Inaktivität verhindern

Interessanter Beitrag - hatte schon gehofft, er würde mir helfen…

Lösung 1 - funktioniert auf meinem Latitude 7490 leider nicht - egal mit welcher Variante.

Lösung 2 - funktioniert zwar, finde ich aber ziemlich „unelegant“ gelöst.

Hast Du eine Idee, warum das mit dem Reg-Eintrag nicht funktioniert?

Hat sich bei dir der Registry Schlüssel wieder zurückgesetzt? Das war bei mir bei einer der beiden Variante der Fall.
Ggbfs. liegt es am Treiber. Bei mir ist der von Windows automatisch ausgewählte aktiv.

Hast du genau das gleiche Problem?

Nur wenn ich die Werte auf „00“ setze. Bei „FF“ bleiben die Werte erhalten, haben aber keine Auswirkung auf das Powermanagement bzw. das „Plopp“.

Weiß ich nicht? Ich nutze den Dell-Audio-Treiber für mein Modell, aus der Treibermatrix. Insbesondere darum, weil dann dmit auch die MAXX-Audio-App installiert wird und der Sound dadurch erst richtig gut wird. Mit Windows-Standardtreiber gibt es bei mir kein „Plopp“, aber der Sound ist so mies, dass ich dann lieber die Dell-Treiber nutze und das „Plopp“ in Kauf nehme.

Ich denke, dann musst du das Stromsparverhalten für den anderen Treiber einstellen.
Beim Windows Standard wird ja der beschriebene Realtek Treiber verwendet.

Vielleicht ist es in deinem Fall ein anderer.

Vermutlich habe ich Dich missverstanden!?

Bei mir wird auch der Realtek-Treiber verwendet. Es gibt die Reg.-Einträge für den Realtek-Treiber und für den Intel-Display-Audio (aber der ist es natürlich nicht).

Ich find’s nur komisch, dass sich dass sich der Stromsparmodus mit der Var. 2 überlisten lässt, aber mit den angepassten Reg.-Einträgen nicht. Aber gut - noch viel „komischer“ ist es, dass ein Hersteller wie Dell sowas nicht in den Griff bekommt bzw. bekommen will. Wobei ich denke, die kümmern sich jetzt einfach nicht mehr um „alte“ Generationen. Bei den neueren ist es nämlich nicht mehr der Fall - also zumindest bei der Latitude-Serie nicht mehr.

Variante zwei wird immer funktionieren. Hat nur den Nachteil des Mikro Symbols in der Taskleiste.

Als dritte Variante wird es sicher funktionieren dauerhaft eine Audiodatei im Hintergrund abzuspielen, die einen nicht wahrnehmbaren leisen Ton ausgibt.

Es kann nur daran liegen, dass er vielleicht doch einen anderen Treiber verwendet, wenn du die Dell Variante nutzt. Leider habe ich deinen Aufbau nicht und kann experimentieren. Vielleicht findet sich etwas im BIOS oder in den Einstellungen des Treibers selbst um das zu verhindern.

Ansonsten habe ich leider keine Idee mehr. Ich selber habe es auf einem neuen Dell der 74er Serie ausprobiert.

PS: ändert sich die Wartezeit bis das ploppen wieder kommt, wenn du die Zeiteinstellung in der Registry von 10s auf 120s hochstellst?

Ich habe kein Micro-Symbol in der Taskleiste bei Var.2. Aber ich halte generell nichts davon, einen Ton oder eine Audiodatei dauerhaft abzuspielen.

Es ist safe der Realtek-Treiber. Die „Dell-Variante“ besagt lediglich, dass noch die MAXX-Audio-App mit installiert wird. Wer weiß, vielleicht war/ist bei Dir auch die Dell-Variante (über Windows-Update) installiert worden und Du weiß es nur nicht?

Auf welchem Gerät genau hast Du es probiert?

Ich habe die beiden Werte mal auf „78 00 00 00“ (120s) gestellt, aber es ändert sich auch nichts.

Bei mir ploppt es immer direkt vor der Wiedergabe von Sound (über Systemlautsprecher oder auch ext. Lautsprecher) und direkt danach.

0

Müsste der Punkt „„MatchingDeviceID““ bei einem Realtek-Treiber nicht eigentlich mit HDAUDIO anfangen, anstatt mit INTELAUDIO :question:

Die MAXX-App habe ich definitiv nicht. Ich habe mal nachgeforscht und es war ein Dell Lat 5520.

Die Zeit, die du dort einstellst, ist die Zeit ohne Sound, bis der Audioprozessor abschaltet.
Daher ich hatte nur ein Plopp im folgenden Fall.
Zeit auf 10s eingestellt, 10s kein Ton (kein Abschaltplopp wahrgenommen). Dann ein Ton → Plopp.
Warte ich die 10s nach einem Ton nicht ab, habe ich kein plopp.

Also ist es bei dir wahrscheinlich ein anderes Problem, da es bei dir sofort und dauerhaft passiert, ohne die Pause wie bei mir.

Bei denn neueren Generationen sind Treiber und MAXX-App getrennt.

Vermute ich inzwischen auch.

Registry: https://www.dell.com/community/Laptops-General-Read-Only/Speakers-popping-on-Inspiron-i7559/m-p/4655473/highlight/true#M860748

Bios Update: https://www.dell.com/community/Laptops-General-Read-Only/Speakers-popping-on-Inspiron-i7559/m-p/4655488/highlight/true#M860763

Vielleicht ist dieser Post hilfreich, da gab es noch einen anderen Schlüssel, bei älteren Geräten.

:+1: Danke - sind bekannt, aber helfen leider nicht.

Ich denke ich werd’s nicht gefixt bekommen und muss damit leben.

Naja…da zwischen den beiden Modellen schon drei Prozessorgenerationen (inkl. anderem Motherboard-Layout) liegen, kann man sich bestimmt schnell mal irren !? Meiner Meinung nach sollte man aber schon wissen, auf welches Gerät man sich genau, in einem Artikel und einem anschließenden Austausch darüber beruft…wäre schon sinnvoll.

Unklar bleibt hier auch weiterhin die Frage, der Treiber / Hardware - Kombination aus dem Screenshot der Registry, die ja irgendwie nicht passend wäre??

0

Da es sich bei dem genannten Fehlerbild, nicht um einen systemischen Fehler handelt, da dieser nur bei vereinzelten Käufern auftritt und die Hersteller sich nicht gezwungen sahen, dagegen einzuschreiten, wäre ein Anwendungsfehler ebenfalls nicht auszuschließen.

Sieht bei mir exkt genau so aus. Entscheidend sind die vorangehenden Werte bei Driver, DriverDesc, InfPath.

Ich habe schon ca. 7-8 Lat. 7490 getestet und es war überall dasselbe. Bei Lat. 7280 genau so. Es sind einfach bestimmte Modelle betroffen bzw. große Teile davon. Aber ich glaube auch, dass es manche entweder nicht stört oder der Sound sowieso deaktiviert ist (z.B. im Büroumfeld).

Ist komplett auszuschließen.

Man kann sicher festhalten, dass es mit dem Powermanagement der Soundkarte zu tun hat, denn nach Anwendung der hier beschr. Var.2 (= Soundkarte auf Dauerbelsatung, damit der Energiesparmodus nicht aktiviert wird) ist das „ploppen“ ja verschwunden.

Danke für deine Antwort!
Allerdings ist in dem Pic auch der InfPath (oem36.inf) nicht richtig definiert, da dieser wohl so aussieht:

oem36. inf uses the INF file extension, which is more specifically known as a Setup Information file. It is classified as a Driver (Setup Information) file, created for Sony Ericsson PC Suite 6.011 by Sony Mobile Communications.01.07.2021

Wenn ich zuvor Anwenderfehler geschrieben hätte, könnte ich dein Argument ja nachvollziehen. Deine Begründung danach, bestätigt ja eigentlich den von mir gemeinten Anwendungsfehler! :wink:
Das es mit dem Powermanagement der Soundkarte zu tun hat, ist mir klar - aus genau diesem Grund, hat man auch in HiFi-Verstärkern, Vorschaltnetzteile eingebaut.
Müsste man dann aber nicht konsequenterweise, den Fokus auf den ACPI-Treiber des Läppis richten? Das Schema von ACPI sieht ja nunmal wie folgt aus im Ablauf:

  1. Das ACPI-BIOS liest oder schreibt Daten in der Betriebsregion eines Geräts.
  2. Um auf den Vorgangsbereich zuzugreifen, ruft der ACPI-Treiber den Vorgangsbereichshandler des Funktionstreibers auf.
  3. Der Vorgangsbereichshandler führt die für den Zugriff programmierte Aktion aus und gibt dem Zugriff zugeordnete Informationen zurück.

…aus diesem Ablauf ergibt sich folgende Anwendung (nicht Anwender) :wink: :

  1. Ein ACPI-Gerät kann auf einen Index in der Betriebsregion eines Funktionstreibers zugreifen, der bewirkt, dass der Treiber eine Soundkartenvolumesteuerung in der vorinstallierten Software eines Anbieters aktiviert wird.

Irgendwie schließt sich in meinen Augen damit auch der Kreis wieder!?

Okay, war schon spät bzw. früh… :wink:

Was sie ACPI-Geschichte angeht, bin ich leider garnicht im Thema und kann dazu nichts sagen - außer - dass wenn es so ist, man (ich) nicht wirklich etwas machen könnte.

Offensichtlich gibt es einen „Bug“ bei gewissen (älteren) Serien, den Dell nicht (mehr) beheben wird oder kann.

Neuere Geräte haben zumindest diesem Bug, nicht mehr. Z.B. habe ich das schon bei meheren Lat. 7410 getestet.

OK…hat jetzt nichts mit der Vermutung zu ACPI zu tun, aber wenn du ein 7490 besitzt…

0

Vielleicht hast du das neue BIOS ja schon? Es ist wohl erst 16 Tage alt - vom 03.03.2022, um genau zu sein! Auch wenn es dein Audio-Prob eventuell nicht löst, wird das Upd. garantiert anderen Müll fixen! :joy: :wink:

…seit 04.03.2022 installiert :grinning:

…der Changelog ist überschaubar:

Zwischenablage01